Monthly Archives: May 2015

FAQs: NetBranch Upgrade for Windows Users

What exactly changed and how did that affect me from connecting to NetBranch? In an effort to provide the highest level of security for members, we disabled connection to NetBranch from devices using any Transport Layer Security (TLS) less than 1.1.Ā  Any device that is not using TLS 1.1 or higher will not be able… Read more »

Net Branch Upgrade for Windows Users

Attention Windows Vista and XP users: Net Branch has upgraded its software to no longer support these two systems. Please refer to the instructions below for manually enabling Net Branch on your computer. Select the browser that you are using to connect to Net Branch: Internet Explorer: Open Internet Explorer Click Alt T and select… Read more »